Support Article
Unable to login to application
SA-29777
Summary
Some of the users are unable to login to the application while others are working on it. Users are getting "Operator ID -- Unauthenticated or not available" error
User Management module which displays all users information is showing blank page.
Error Messages
1.While trying to login facing the below error message:
'Operator ID -- Unauthenticated or not available'
2.While opening the operator profile from designer studio facing the below error message:
'Failure opening the Rule instance'
Steps to Reproduce
Log into Site Health Application using the credentials of the users (who are facing the issue). Receive error message that Status :fail and Operator ID: Unauthenticated or not available
Root Cause
A software use or operation error, as tested for BLOB data for the reported operator ID ‘XXXX’ in dev environment (by creating an activity which will do ‘Obj-Open-By-Handle’ and ‘Show-Page’) which returned all the BLOB content related to that operator instance in dev environment.
However when user tested with the same test activity (in a ruleset not in production) it returned no BLOB content, with which came to a conclusion that BLOB got the corrupted for operator ID ‘XXXX’ in Production.
Resolution
Delete the record specific to operator ‘XXXX’ in ‘pr_operators’ table (with the backup) and recreate the same operator ID from designer studio with ‘external authentication’ checked to login with LDAP URL.
Published November 15, 2016 - Updated October 8, 2020
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