Support Article

Upgrade to 7.1.6 "Failed to find current installed version"

SA-3827

Summary



Admin attempting to upgrade from PRPC 7.1.4 to 7.1.6.  Running the upgrade script fails each time trying to determine the current PRPC version.


Error Messages


 

Running with JDBC trace shows on shows us what the error is.

SEVERE: 1B5E1B5E Throwing SQLException: ORA-01031: insufficient privileges

The user running the upgrade did not have the privileges to query the database table.  


Steps to Reproduce



Run ./upgrade.sh


Root Cause



The root cause of this problem is a defect/misconfiguration in the PRPC operating environment.


Resolution



This issue is resolved by making the following change to the PRPC operating environment: 
DBA grants the deployment user the privileges to read/write the tables in the rules and data schema.  
Suggest Edit

Published January 31, 2016 - Updated October 8, 2020

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.