Support Article

Upgrade fails - DB permissions

SA-10154

Summary



Error messsages are generated when upgrading from Pega 7.1.6 to Pega 7.1.7.

Error Messages



[java] INFO: GRANT ALL ON
[java] May 20, 2015 8:05:33 PM com.pega.pegarules.install.SQLLoader writeMessage
[java] WARNING: Failed to execute SQL in file oracledate00490.sql
[java] May 20, 2015 8:05:33 PM com.pega.pegarules.install.SQLLoader writeMessage
[java] WARNING: Statement: GRANT ALL ON DATA_PEGA7.pwbv4_circumstance_duplicates TO RULES_PEGA7
[java] java.sql.SQLSyntaxErrorException: ORA-01749: you may not GRANT/REVOKE privileges to/from yourself
[java]
[java] at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:439)


Steps to Reproduce



Not Applicable

Root Cause



The root cause of this problem is software use/operation error. The deployment user does not have the correct permissions applied. 

Resolution



Grant DBA privileges to the deployment user, which is only used during install/upgrade time. Refer notes in the upgrade guide regarding the deployment user. Further, the deployment user is discussed in detail in the installation guide (any of the guides for the Oracle database), and the specific permissions are detailed. 

Upgrade guide:  https://pdn.pega.com/documents/pega-717-upgrade-guide
One of Pega 7.1.7 Installation Guides for Oracle:  https://pdn.pega.com/documents/pega-717-installation-guide-for-websphere-on-oracle
Suggest Edit

Published June 12, 2015 - Updated October 8, 2020

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.