Support Article
Unable to add or update Index Host Node after Jboss6/PEGA7 setup
SA-10505
Summary
Issue with adding "Search Index Host Node Settings" in DesignerStudio Search landing page. Also, after clicking on Re-index button in the search landing page, the functionality is not indexing the rules and data.
Error Messages
Not Applicable.
Steps to Reproduce
1.Setup new Pega 7.1.7 environment on JBoss 6.2x application server.
2.After bringing up the application, re-index all the rules and data.
3.Update the indexing hostname, indexing host ID.
4.Add or update the indexing host node in the Search landing page.
Root Cause
On Pega v7.1.7 the below mentioned Dynamic System Settings (DSS) must be configured for proper working of ElasticSearch functionality.
- indexing/distributed/enabled
- indexing/distributed/index_enabled
Issue gets resolved on configuring DSS settings by following these steps:
1.Shutdown the nodes
2.Clear the table pr_sys_statusnode (take a backup for reference).
3.Start the first node.
4.Once the node starts successfully, verify the table pr_sys_statusnode. It should contain one entry corresponding to this node and will become default search node.
5.Re-index the rules and data.
6.Add additional nodes based on the requirements.
Once the re-indexing is completed (on migration to Pega v7.1.7) you can disable Systemindexer and SystemWorkindexer Agents as they are relevant only to Lucene search.
The FTSIncrementalIndexer agent is relevant to ElasticSearch functionality and must be run on all index host nodes.
Resolution
Perform the following steps to resolve the issue:
1.Configuring the DSS settings corresponding to the ElasticSearch functionality.
2.Bouncing the server on clearing the pr_sys_statunodes table data.
Published June 24, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.