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Support Article

Incorrect response message in Email Listener Service-Response

SA-15335

Summary



A custom response message is added in the email Listener Service-Response tab. Sporadically, a Pega Response (No Records To Process) is generated instead of the custom response message.


Error Messages



Not Applicable


Steps to Reproduce



1. Try to send an email to the email listener account with an Invalid ObjectId as subject
2. Check the response received


Root Cause



An issue in the custom application code or rules. The activity used to process the incoming email request is configured incorrectly. The property set method used to set the response body content, was unable to override the OOTB error messages.

Resolution



Perform the following local-change:

Add a Page-New step of response mail, before setting the response body contents, such that all the properties present on the response body will be reset.

Published January 31, 2016 - Updated October 8, 2020

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