Support Article
Error in log file when login from Salesforce, using IAC gadget
SA-20014
Summary
When attempting to log into a Pega app displayed in IAC gadget within Salesforce, an error is thrown: Error while decoding access group (default)
java.lang.IllegalArgumentException: Null input buffer
Error Messages
Error is shown in log.
Error while decoding access group (default)
java.lang.IllegalArgumentException: Null input buffer
Steps to Reproduce
1. Login through Salesforce and open Pega tab
Root Cause
Customer is accessing the PEGA application from a Salesforce or SFDC (Sales Force Dot Com) application via a gadget. However gateway is not being used for this communication. The variable pega.web.config.systemID="default" is only used when accessing the Pega application through the Gateway. The value for this variable is the one, we have used in the "Connection Name" field during host configuration in IAC. In this particular case the value is "default" but it can be any name. To access the Pega application from SFDC we need the gadget code and for this, there is a one time job to setup the gateway and download the gadget code and the .js files. Customer is not using the gateway, instead they are directly calling the PEGA in the gadget code, but at the same time they are using the parameter "pega.web.config.systemID="default". This is causing error message in the Pega log file but this error doesn't cause any other side effect.
Resolution
Recommended customer a local change to remove the setting "pega.web.config.systemID="“ from the gadget code, referred in the Salesforce application tab, which displays the Pega application.
Published February 27, 2016 - Updated October 8, 2020
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