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Support Article

Search rule does not work

SA-20487

Summary



User is not able to  search rules in the Pega 7 environment. 

Error Messages



Search rule returns nothing


Steps to Reproduce

  1. Copy a database from PRPC 6.2.2 to a new database.
  2. Upgrade to Pega 7.1.6 then to 7.1.9.
  3. Start application server.
  4. New application server on Linux and Websphere.
  5. Start search index.


Root Cause



A defect or configuration issue in the operating environment .
The indexing required for search was not finished properly. If 
the indexing is done completely without any interruption then the DSS value is set to true.
However, if it finishes with error or faces an abrupt end, then the DSS will set to false .This is exactly the cause here. The DSS was set to false.

 

Resolution



Perform the following local-change: 

Set the value for  PEGA-SEARCHENGINE!INDEXING/DISTRIBUTED/SEARCH_ENABLED to true.

 

Published March 5, 2016 - Updated October 8, 2020

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