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Support Article

FTSIncrementalIndexer agent : queue size large

SA-21927

Summary



Newly created work objects are not searchable with Pega 7.1.8.


Error Messages



Not applicable


Steps to Reproduce

  1. Create new work object from the Case Manager portal.
  2. Search for the newly created work object from the search gadget.


Root Cause



A defect or configuration issue in the operating environment.

When navigated to Search Landing Page > Agent Information section, this section displays the status of the FTSIncrementalIndexer agent that incrementally update the search index files as changes are made to RULE-, DATA-, and/or WORK- instances. Display provides following information:

 Agent name
 The number of entries currently in the queue
 The age of the oldest entry in the queue

From the screen capture below, its clear that the number of entries in the queue is large because there are some custom classes that are getting updated very frequently which are generating too many entries in the pr_sys_queue_ftsindexer table. This is causing a mismatch between the indexes on the pr_sys_queue_ftsindexer table and the business logic code, causing the queries to find the 'first' pending index request to run slowly and the indexer to fall behind. The slowness grows over time as it is a factor of the index queue table depth.



Resolution



Perform the following local-change:

Run the following SQL Select below, this will give the count of instances per class in the  pr_sys_queue_ftsindexer table.

It will tell if there are any classes which are generating too many entries in the table and clogging the queue. Check if these classes are really meant to do so many changes.

If not, revisit the application logic:


select count(pxworkkey), pxworkclass from pr_sys_queue_ftsindexer group by pxworkclass order by count(pxworkkey) DESC;

Perform the following change:

1.       Purge pr_sys_queue_ftsindexer table.
2.       Stop the JVM.
3.       Purge all the contents in the search index directory.
4.       Start the JVM.
5.       Go to SMA and make sure FTSIncrementalAgent is running.
6.       Go to search landing page and manually begin indexing RULE-, DATA-, WORK-
7.       Make sure FTSIncrementalAgent is running every 60 seconds.

Published November 4, 2016 - Updated October 8, 2020

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