Support Article
no PRPCGateway logs in Websphere
SA-40320
Summary
In Websphere, despite activating log in the prgateway console, user is unable to fetch these logs.
It works fine in Tomcat application server.
Error Messages
Not Applicable
Steps to Reproduce
Activate logs in prgateway console.
Root Cause
Websphere is using the same logging mechanism as PRPC and overwrites PRPC configuration.
Hence logging needs to be configured through the Websphere console.
Resolution
With a Websphere application server, Prgateway logs are written in System.out log file by default.
On a Windows system, this file lives in the following location:
On a Windows system, this file lives in the following location:
\WebSphere\AppServer\profiles\AppSrv01\logs\server1
In order to active the desired level of logging (such as DEBUG), this needs to be done through the Websphere console instead of the Prgateway console using the below step:
In the Websphere console, go to Troubleshooting >Logs and Trace then under "Component and Group" find and set log level for class com.pega.pegarules.gateway.
Published September 8, 2017 - Updated October 8, 2020
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