Support Article
JNDI Server field in Connect-JMS doesn't support GRS
SA-43855
Summary
User is using Pega 7.2.1 and reported that setting the value of JNDI Server field present in Connect_JMS rule form using Global Resource Setting doesn't work.
It works when the JNDI Server rule instance is specified directly but when the same value is set in the JNDI Server field using Global Resource Setting then system throws the below error:
Could not find JNDI Server instance: =D_PegJMS.PegJNDIProp
Per Pega help documentation this field supports GRS (Global Resource Settings).
Error Messages
Could not find JNDI Server instance: =D_PegJMS.PegJNDIProp
Steps to Reproduce
- Create a Connect-JMS rule.
- Configure a JNDI Server rule instance.
- When doing test connectivity by specifying the JNDI Server rule instance directly on Connect-JMS rule form then the connectivity is successful.
- But when setting the value of JNDI Server name using GRS on the Connect-JMS rule form then the test connectivity fails with error message.
Root Cause
A defect in Pegasystems’ code or rules is identified as root cause of this issue.
Resolution
Perform the following local-change:
- Save the Rule : ValidateInfrastructure ; CL :Rule-Connect-JMS ; RS : Pega-IntegrationEngine to application ruleset.
- Add a local variable actualJNDIServerName of type string.

3. Add a Java step 3 with step page as JNDIServerPage to get actualJNDIServerName from pega.getServiceUtilsPriv().getStringIndirect.


Published December 14, 2017 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.