Support Article
Agents not showing in SMA and under search settings
SA-3486
Summary
Intermittently, User experiences the Agent Status screen in the System Management Application (SMA) does not show agent information. This information does not return until the system is restarted by user. Likewise, the Search settings in PRPC also does not has the node details.
Steps to Reproduce
Access agents administration landing page in PRPC or Agent Management in SMA
Root Cause
User is running with a multi-node environment and was not able to see the agents running on a particular node from System Management Application (SMA). And. also on the Search-settings landing page for a particular node.
Resolution
Suggested user to verify the following:
-SMA node should be mapped to the pxSystemNodeID as seen on clipboard(System Pages -> pxProcess -> pxSystemNodeID).
-Go to SMA-> Node -> Agent Management -> Agents and check that all the Agents work fine as expected
When a Agent is down you need to look at the “Last run time” “Last finish time” “Next run time” “Exception Info” since some agents are scheduled for a relative time interval.

-Particular Agent rule should be enabled for a particular node (i.e. monitored by SMA) can be reviewed as follows.

Published January 31, 2016 - Updated October 8, 2020
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