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Support Article

Accessing "System Queue Management" report in SMA throws error

SA-23096

Summary



User is running System Management Application (SMA) for Pega 7.1.6 on Websphere 8. User is getting the below exception when trying to access "System Queue Management" in SMA:

com.pega.jmx.ui.util.JMXClientException: Node: <Node Name> Exception: com.pega.jmx.ui.util.JMXClientException: Failed to invoke an operation
java.lang.Exception: Failed to invoke MBean operation.
Name: com.pega.PegaRULES:cell=<Cell> Cell,id="<Cell ID>", name=com.pega.pegarules.management.internal.SystemQueueManagement,node=<Node>,process=<Process>,type=enterprise opName: SystemQueueSummary
Failed to invoke MBean operation
ADMC0009E: The system failed to make the SOAP RPC call: invoke


Error Messages



com.pega.jmx.ui.util.JMXClientException: Node: <Node Name> Exception: com.pega.jmx.ui.util.JMXClientException: Failed to invoke an operation
java.lang.Exception: Failed to invoke MBean operation.
Name: com.pega.PegaRULES:cell=<Cell Name> Cell,id="<Cell ID>", name=com.pega.pegarules.management.internal.SystemQueueManagement,node=<Node>,process=<Process>,type=enterprise opName: SystemQueueSummary
Failed to invoke MBean operation
ADMC0009E: The system failed to make the SOAP RPC call: invoke
at com.pega.jmx.ui.util.JMXClientException.wrap(JMXClientException.java:49)
at com.pega.jmx.ui.action.PerformDefaultOpAction.execute(PerformDefaultOpAction.java:306)
at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)
at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1480)
at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:506)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:575)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:668)

 

Steps to Reproduce

  1. Open System Management Application.
  2. Navigate to Node > Agent Management > System Queue Management report.
  3. Trying to open "System Queue Management" report gives JMXClientException exception.


Root Cause



A defect or configuration issue in the third party product integrated with Pega is identified as the root cause of this issue. 

Resolution



Consult with application server vendor and provide "ADMC0009E Getting Connection Reset On Syncronization Attempt" as the error description for investigation.

Published May 12, 2016 - Updated October 8, 2020

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