Support Article
Activity called 3 times when submitting intent task
SA-5488
Summary
You observe that CAVerticalMoveTaskToInProgress is called three times when submitting an intent task. This causes extra network traffic and strain on the database.
Error Messages
Not Applicable
Steps to Reproduce
1. Create a new interaction
2. Open an Intent task
3. Submit the intent task
Root Cause
This issue was caused by custom code to refresh the entire composite when a Service Intent was closed. There is a bug in the Pega code that reloads the iFrame for every tab during composit refresh, even for tabs that are currently in a deferred load state and not yet loaded. This causes the CPM system to treat that tab as if it has just been selected from the TODO list, with the resulting call to CAVerticalMoveTaskToInProgress
Resolution
HFix-20017 fixes the issue.
Published January 31, 2016 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.