Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

ADM Server times-out with remote access exception

SA-12877

Summary



Connection to ADM Server times-out with an exception.


Error Messages



java.net.SocketTimeoutException: Read timed out exception


Steps to Reproduce



Not Applicable


Root Cause



The root cause of this problem is defect/misconfiguration in the operating environment. Server is trying to read data from the request, but it takes longer than the timeout value for the data to arrive from the client.
The issue is caused by network delay or availability of ADMServer and is not a product BUG.


Resolution



The explanation for this behavior is as follows: 
  • When you see this issue, validate if ADMServer is accessible or not.
  • Investigate if there is any delay in network which could be causing this.
  • Validate connectionTimeout attribute setting and adjust if required based on your requirement.
  • Increase OpenFiles from 1024 to higher value using ulimit command.

Published August 28, 2015 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us