Support Article
Advanced agents do not run in the application
SA-84981
Summary
Advanced agents do not run in the application.
Error Messages
Fail:Not found
Steps to Reproduce
Open the Agents landing page from the Pega Admin Studio. Verify the status of the agent.
Root Cause
In the user's application, the agent is configured with the 'Advanced' mode. The agent activity performed the RDB-Open on a class which returned 0 results when the database is queried. Therefore, the exception occurred.
For more information, refer to: https://community.pega.com/sites/default/files/help_v81/procomhelpmain.htm#methods/rdb-open/rdb-open.htm
In the Advanced agents, the agent activity is responsible for both transactional and business processing. According to the functionality based on the agent activity status, the respective agent is disabled or is scheduled for the next run. In this use case, since the activity displays an error, the agent is disabled.
Resolution
Perform either of the following local-changes:
- Change the agent mode.
- Manage the error scenarios in the agent activity while retaining the agent mode as Advanced.
Published August 19, 2019 - Updated December 2, 2021
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