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Support Article

AES Scorecard reports not displaying on screen

SA-34011

Summary



The dashboard with weekly scorecards and other reports will not display.

Error Messages



This is a sample set of a problem querying the alert table.
Database operation took more than the threshold of 500 ms: 23,829 ms SQL: SELECT COUNT(ASTERISK) AS "pySummaryCount(1)" FROM DATA.pegaam_exception "PC0" WHERE ( "PC0".PXCREATEDATETIME >= ? AND "PC0".PXCREATEDATETIME ? AND "PC0".CLUSTERNAME = ? AND "PC0".PROBLEMCORRELATION IN (SELECT "PARENTWorkException".L1 AS "SRCOL1" FROM ( SELECT "WorkException".PROBLEMCORRELATION AS "L1" , ROW_NUMBER() OVER (ORDER BY "WorkException".PXURGENCYWORK DESC NULLS LAST) AS "L2" FROM DATA.pegaam_exception_work "WorkException" WHERE ( "WorkException".PYSTATUSWORK NOT LIKE ? AND "WorkException".PXURGENCYWORK > ? AND "WorkException".CLUSTERNAME = ? ) AND "WorkException".pxObjClass LIKE ? ) "PARENTWorkException" WHERE "PARENTWorkException".L2 = ? ) ) AND "PC0".pxObjClass = ?
This query is for this report CurrentWeekTotalExceptionCount.
Database operation took more than the threshold of 500 ms: 30,806 ms SQL: SELECT COUNT("PC0".MSGID) AS "pySummaryCount(1)" , COUNT(DISTINCT "PC0".FIRSTACTIVITY) AS "pySummaryCount(2)" FROM DATA.pegaam_alert "PC0" WHERE ( "PC0".CLUSTERNAME = ? AND CASE WHEN "PC0".GENERATEDDATETIME IS NOT NULL THEN "PC0".GENERATEDDATETIME+? END >= ? AND CASE WHEN "PC0".GENERATEDDATETIME IS NOT NULL THEN "PC0".GENERATEDDATETIME+? END = ? ) AND "PC0".pxObjClass = ?
This alert is from AlertsForClusterOnDailyDataPage
[MSG][An error occured on executing the query for the report definition - There was a problem getting a list: code: 1013 SQLState: 72000 Message: ORA-01013: user requested cancel of current operation][STACK][com.pega.pegarules.pub.database.DatabaseException: There was a problem getting a list: code: 1013 SQLState: 72000 Message: ORA-01013: user requested cancel of current operationFrom: (H8E7F230B98BF350B951685A43CDFAAE2:your_ip) SQL: SELECT COUNT("PC0".MSGID) AS "pySummaryCount(1)" , COUNT(DISTINCT "PC0".FIRSTACTIVITY) AS "pySummaryCount(2)" FROM DATA.pegaam_alert "PC0" WHERE ( "PC0".CLUSTERNAME = ? AND CASE WHEN "PC0".GENERATEDDATETIME IS NOT NULL THEN "PC0".GENERATEDDATETIME+? END >= ? AND CASE WHEN "PC0".GENERATEDDATETIME IS NOT NULL THEN "PC0".GENERATEDDATETIME+? END = ? ) AND "PC0".pxObjClass = ? SQL Inserts: 0.0> 20170201T050000.000 GMT> 0.0> 20170208T050000.998 GMT>


Steps to Reproduce



Not Applicable


Root Cause



A defect or configuration issue in the operating environment

The AES agents were not actively trimming the pegaam_alert and pegaam_exception tables.

Resolution



Make the following change to the operating environment:

Make sure that the AES agents are running on all nodes in the AES server cluster.
​Contrary to past AES configurations AES 7.1.7, AES 7.2, and later require that the agents run on all nodes in the AES server cluster. The implementation of the agents allows for fail over should one node in the server cluster fail or be quiesced.

From the SMC console Agent Management > Agents, make sure that each node has these agents enabled



If you are using AES to monitor the AES servers, then the display would look like this when selecting Agents for the individual node (this shows a Multi-Tenant environment)

Published March 26, 2017 - Updated October 8, 2020

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