Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

After committing hotfixes, they still show as uncommitted

SA-13395

Summary



After committing a list of hotfix items on the update manager page, they still show on the uncommitted list.

Error Messages



No error is displayed, the list of uncommitted hotfixes never clears.

After clicking on the "Commit All" button, successful message is given





But the HFIXes still show in the Ucommitted list.


Steps to Reproduce



Click on "Commit All" button in Update Manager page.

Root Cause



The root of this issue is that the values for the column pyUniqueID are larger than the 16 characters used for the column size.
The value gets truncated upon insert and when tried to use it as a key to link rows and user is not able to find anything.

 

Resolution



This issue is resolved through the following local-change:

Increase the column size of pyUniqueID from 16 character to 32 character. pyUniqueID value is also saved in the pxInsName column, hence populating each row's pyUniqueID column with the value from pxInsName column. Thereafter restart the JVM and commit the hotfixes from update manager page.

Published August 27, 2015 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us