Support Article
Agent is not working after migrating to different environment
SA-7012
Summary
After migration PRPC from one environment to another, user observes that an agent is not working anymore.
As an example, PRPC is not sending email anymore via the SendCorr agent.
Error Messages
Not Applicable.
Root Cause
In this example, user has designed their application such that the SendCorr agent need a specific access group.
The reported issue is caused by a missing access group for the schedule, present in that agent queue instance that is responsible for sending email.
When a new environment is built, a new node ID is created and so new Agent Schedule rule is created based on Agent rule.
In this case, the previous environment had an access group specified in the security tab of each Pega-ProCom Agent Schedule rules.
The OOTB Pega-ProCom Agent rule does not have access group specified in the security tab.
Hence when the new environment is created, the newly created Pega-ProCom Agent Schedule rule did not have an access group defined in the security tab.
Resolution
The solution is to edit all new Agent Schedule rules in the new environment and add missing access group in the security tab (as it was in the previous environment).
Published January 31, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.