Support Article
Agent process failing
SA-14032
Summary
An agent process that was previously working now fails with errors due to an failed instance of a certain rule.
Error Messages
Failed to find instance Class.RuleName of type Rule-Obj-When.
Steps to Reproduce
- Upload an element into the agent queue.
- Open SMA and select to delay the agent of interest.
- Select the Requestor link and click the radio button aligned to the Requestor matching the agent.
- Click Tracer button. Observe the instance error.
Root Cause
An issue in the custom application code or rules. The issue is that the agent schedule and agent record were not synchronous and the agent running did not have the proper access to see the rules of interest.
Resolution
Perform the following local-change:
- Update the agent rule to specify the necessary access group on the security tab.
- Delete all linked agent schedules that are linked on the nodes tab.
- Restart the JVM and test the scenario of interest.
Published September 11, 2015 - Updated October 8, 2020
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