Support Article
Agent schedule is generated with incorrect schedule after import
SA-44216
Summary
A new version of an agent rule was imported, which modified the schedule for an agent, and the Data-Agent-Queue instances were deleted. When the schedule instances were regenerated, the schedule was incorrect.
The xml for the Data-Agent-Queue instance shows the correct ruleset version; however, the schedule for the agent was from the prior version.
Error Messages
Not Applicable
Steps to Reproduce
- Import a new agent rule with an updated agent schedule.
- Delete the agent schedule instances.
- Stop/start the agent from the Agents landing page.
- Check the agent schedule that was generated.
Root Cause
The Data-Agent-Queue schedule instances need to be deleted and then regenerated via the MasterAgent. The start/stop of the agents via the Agents landing page is only designed to create the Data-Agent-Queue instance from memory so it does not read the schedule from the latest Rule-Agent-Queue instance.
Resolution
After importing the new agent rule, delete all of the agent schedules and allow them to regenerate via the MasterAgent so they will be generated from the latest version of the rule.
Note: Enhancement request FDBK-22928 has been submitted to review the Agents landing page functionality in a future release. BUG-329109 was entered to update the Help documentation.
Published November 5, 2017 - Updated October 8, 2020
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