Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Agent State not updating after logging into the softphone

SA-31551

Summary



A PegaCALL 7.1.3.3 application has been upgraded to PegaCALL 7.1.3.4.

After the upgrade, the CTIToolbar is not functional. The green available icon not showing after a
Customer Service Representative (CSR) has login to CTI.


Error Messages



No error message is getting displayed upon logging in.


Steps to Reproduce



1. Switch on the CTI Link event.
2. Log into the CPM portal.
3. Log into the softphone. After logging in, the agent state is not getting reflected in the portal. Hence the CSR does not know whether they have logged in or not.


Root Cause



The previous application has been configured with OCX as Present Agent.

The new requirement is to use No-Plugin. The configuration need LongPolling mechanism to be functional.

Since the custom application has customized the PegaCallContainer section by removing the LongPollerWrapper section, the LongPolling will not able to be initialized. 


Resolution



Include LongPollWrapper in PegaCallContainer section in PegaCallContainer, if No-Plugin is being used.

 

Published January 12, 2017 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us