Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Agents bring down node

SA-23756

Summary



Pega Platform nodes with a group of four business logic agents running go down shortly (about a minute) after startup.

The "go down" is observed by a lack of responsiveness to requests and a thread dump in the logs. 

Error Messages



"[ACTIVE] ExecuteThread: '3' for queue: 'weblogic.kernel.Default (self-tuning)'" daemon prio=10 tid=0x00007ffddc004000 nid=0x1567 runnable [0x00007ffdf47e0000]
     java.lang.Thread.State: RUNNABLE
     at java.net.PlainSocketImpl.socketConnect(Native Method)
     at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
     - locked < 0x000000060818aa68> (a java.net.SocksSocketImpl)
     at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
     at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
     at java.net.Socket.connect(Socket.java:579)
     at oracle.net.nt.TcpNTAdapter.connect(TcpNTAdapter.java:161)
     at oracle.net.nt.ConnOption.connect(ConnOption.java:159)
     at oracle.net.nt.ConnStrategy.execute(ConnStrategy.java:428)
     at oracle.net.resolver.AddrResolution.resolveAndExecute(AddrResolution.java:506)
     at oracle.net.ns.NSProtocol.establishConnection(NSProtocol.java:595)
     at oracle.net.ns.NSProtocol.connect(NSProtocol.java:230)
     at oracle.jdbc.driver.T4CConnection.connect(T4CConnection.java:1452)
     at oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:496)
     at oracle.jdbc.driver.PhysicalConnection.connect(PhysicalConnection.java:666)
     at oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:32)
     at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:566)
     at java.sql.DriverManager.getConnection(DriverManager.java:571)
     at java.sql.DriverManager.getConnection(DriverManager.java:215)
     at com.pega.pegarules.data.internal.access.ConnectionManagerImpl.getConnectionFromDatabaseName(ConnectionManagerImpl.java:769) ...
 

Steps to Reproduce

  1. Start business processing agents.
  2. Observe the node becomes unresponsive and a thread dump is present in the Pega logs.


Root Cause



A defect or configuration issue in the operating environment. The agent in question was attempting to access a certain database schema which had connection information that was no longer current following a database move. The schema or database target was identified with the use of the debug logger on the class ConnectionManagerImpl.

Resolution



Perform the following local-change:

Update the database target connection information to point to the latest configuration.

 

Published June 6, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us