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Support Article

Agents go to Exception stage post upgrading to Pega 8.3

SA-92730

Summary

Agents go to Exception stage post upgrading to Pega 8.3.


Error Messages

Exception at 20191021T095935.401 GMT:
pega.pegarules.pub.PRRuntimeException: unable to execute agent: Cuttyhunk #5: System-Queue-SchedulerTask.PerformScheduledTasksUnable to open context
at pega.pegarules.session.internal.async.agent.QueueProcessor.execute(QueueProcessor.java:719)
at pega.pegarules.session.internal.async.BatchRequestorTask.run(BatchRequestorTask.java:1157)
at pega.pegarules.session.internal.PRSessionProviderImpl.performTargetActionWithLock(PRSessionProviderImpl.java:1382)
at pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:1125)
at pega.pegarules.session.internal.PRSessionProviderImpl.doWithRequestorLocked(PRSessionProviderImpl.java:1006)
at pega.pegarules.session.internal.async.BatchRequestorTask.run(BatchRequestorTask.java:817)
at ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at Thread.run(Thread.java:748)


Steps to Reproduce

  1. Open the Admin Studio
  2. Select Agents
  3. Select Scheduler
  4. Start the agents


Root Cause



A defect in Pegasystems’ code or rules. Step status is set to Fail in one of the steps of the activity. The status is not reset when the activity completes. Hence, the agents fail with the exception when they are executed in the next run.

Resolution



Perform the following local-change:
Add activity-clear-status as the last step in the activity. 

 

Published November 5, 2019 - Updated December 2, 2021

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