Support Article
Assigning cases do not work as expected
SA-14634
Summary
GetNextWork evaluates local action with when condition wrongly.
Local Actions are configured with When rules on Stages tab of case type rule. When an assignment is assigned through GetNextWork, the When rules are evaluated before assignment and thereby, the wrong local actions are presented.
Error Messages
Not Applicable
Steps to Reproduce
1. Log in to Pega.
2. Click Next Assignment. The case gets assigned to the currently logged user.
3. When the case opens, navigate to Other Actions. Incorrect local actions are listed.
Root Cause
GetNextWork activity population of flow actions needs to be corrected.
Resolution
Local-change is to override GetNextWork activity and perform the below changes:
1. Add a new step after step 4 and call activity "Call Work-.pxPopulateFlowActions".
2. Add step page as "Param.workPage".
3. Move the step label "A" from step 6 to the newly added step which is step 5.
Published October 13, 2015 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.