Support Article

Assignment SLA Deadline event running on resolved WOs

SA-38581

Summary



Assignment SLA Deadline event still executes after resolving a case.

Once the Work object (WO) are resolved the assignment entry from pc_assign_worklist or pc_assign_workbasket class is getting deleted.

The SLA deadline event is getting invoked and corresponding events are getting fired.


Error Messages



Not Applicable


Steps to Reproduce

  1. Create a case.
  2. In the assignment shape add repeat of the late event for SLA for say 3 times for sending emails.
  3. Resolve the request. Still email is received.


Root Cause



An issue in the custom application code or rules.

The SLA agent was running on multiple nodes but it's reference Dynamic System Setting were configured for single node use.

Resolution



Perform the following local-change:

Change the Dynamic System Setting 'SLARefreshEachListIteration' to true for Multi- Node Production system.

Published May 26, 2017 - Updated July 10, 2017

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