Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Autocomplete functionality is not working properly

SA-21767

Summary



User used minimum search character in 'Autocomplete' control as three in most of the cases, If  three characters are typed and searched, it is displaying the results correctly (Words that have that three characters). Then If user types one more character(fourth character) then incorrect results are displayed.

Error Messages



No error message.


Steps to Reproduce

  1. Create a section with autocomplete.
  2. In that control, configure with Report Definition to display list of some results, for example: Name. Set 'Minimum Search Characters' to three.
  3. ​Then type fourth letter and press down arrow. It will display results which are not related to search term.


Root Cause



A software use or operation error: User was trying to show maximum display results as 1000, due to which the refresh was taking longer time.

Resolution



Perform the following local-change:

Change the maximum results displayed from 1000 to 50 resolved the issue.

Below is the screen shot of the setting.

 

Suggest Edit

Published April 6, 2016 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us