Support Article
Bell icon Notifications do not display in recipients portal
SA-106817
Summary
On assigning a work object to a user, a 'Send notification' smartshape is configured to send a notification. However, the notification is not received by the end user. The gadget Bell icon does not display the Counter or the message.
Error Messages
Not Applicable
Steps to Reproduce
- Create a Notification rule.
- Configure a 'Send notification' smartshape in a flow to send the notification.
- Execute the flow.
Root Cause
An issue in the custom application code or rules.
The sender was sending a notification to itself. This is incorrect according to the configuration.
The data page used for the Notification rule is D_OperatorID.

When the data page is opened, it is of type 'Page' and is sourced from the data transform.

The data page only copies the current operator to a primary page, as per its implementation.

According to the implementation, when Operator A initiates the Notification rule, the data transform retrieves the same operator details and assigns them to the data page results. That is, a notification is sent to the sender itself. Pega or any Notification application, according to the standards, will not send a Notification message to the sender. Hence, the sender does not receive any notification.
Resolution
Perform the following local-change:
- Ensure that the Recipient or Recipient list is present when executing the data page referred in the Notification rule.
- Ensure that a notification is not sent to the sender itself.
- Ensure that the Operator ID property is referred correctly in the Recipients section of the Notification rule.
Published June 17, 2020 - Updated December 2, 2021
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.