Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

BIX is adding two extra columns



Pega 7 Business Intelligence Extract (BIX) rule is adding below two extra columns which is causing downstream system's processes, which consume BIX extract files to get failed.
  • pxExtractIdentifier
  • pxExtractDateTime

User is looking for a way they can avoid these two columns appearing in the BIX extract file.

Error Messages

Not Applicable

Steps to Reproduce

Run Pega 7 BIX extracts and observe pxExtractIdentifier and pxExtractDateTime column in extract output.

Root Cause

Not Applicable


Include below prconfig.xml setting and restart the server to exclude the columns in extracted data.

Example: <env name="bix/removeAdditionalColumnsInCSV" value="pxExtractIdentifier,pxExtractDateTime"/>

Published October 5, 2017 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us