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Support Article

BIX is not working as expected

SA-44983

Summary



The user is seeing an blank pop-up getting displayed upon launching the existing extract rule or after saving the new one.

Also, upon saving the application ruleset with the new Business Information Exchange (BIX) ruleset, it throws an reported error on screen and in the tracer output.


Error Messages



Below SQL and error, while trying to save the application rule set after including the Pega-BIX:07-10 rule set.

SQL Query:

insert into RXPQ.pr_sys_ruleset_index (PXCREATEDATETIME , PXCREATEOPNAME , PXCREATESYSTEMID , PXINSNAME , PXOBJCLASS , PYRULESETVERSION , PZRULESETINDEX , PZRULESETLISTHASH , PZRULESETNAME , PZRULESETVERSIONMAJOR , PZRULESETVERSIONMINOR , PZRULESETVERSIONPATCH , pzInsKey) values (? , ? , ? , ? , ? , ? , ? , ? , ? , ? , ? , ? , ?)

<2017-10-04 09:49:41.82> <Madan Kaniyampati> <d71bdfeffcb15d8dc35042ea09f95a0d> <025B619B87E62CF096631430B903FAFF!PEGA-PROCESSCOMMANDER> <System-RuleSet-Index> <07-10-99> <1> <025b619b87e62cf096631430b903faff> <Pega-ProcessCommander> <7> <10> <99> <SYSTEM-RULESET-INDEX 025B619B87E62CF096631430B903FAFF!PEGA-PROCESSCOMMANDER>

Error :

Save failed: : code: -803 SQLState: 23505 Message: DB2 SQL error: SQLCODE: -803, SQLSTATE: 23505, SQLERRMC: 1;RXPQ.PR_SYS_RULESET_INDEX

** Java Exception: java.lang.IllegalStateException: Internal state is compromised; cannot add new ruleset list to the database


Steps to Reproduce



1. Import BIX 7.1.5 distribution in Pega 7.1.5 instance.
2. Configure the BIX as per the user guide.
3. Launch or create a new extract rule.
4. Observe the blank popup gets displayed.
5. Try to save the application ruleset with BIX 07-10-09 version and see the error is getting displayed in UI and in the tracer output.


Root Cause



A defect or configuration issue in the operating environment:

There is a duplicate record in the table PR_SYS_RULESET_INDEX which needs be deleted.

Resolution



Make the following change to the operating environment:

1. Delete the duplicate record.
2. Try saving the application ruleset.
3. Logout and login back.
4. Test creating a new extract rule or launch an existing one.

Published February 7, 2018 - Updated October 8, 2020

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