Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Blue screen displays when logging in to the application

SA-89897

Summary



A blue screen displays when logging in to the application.


Error Messages



com.pega.pegarules.pub.PRMissingContextError][STACK][com.pega.pegarules.pub.PRMissingContextError: Cannot restore passivated page 'pyPortal' for Thread


Steps to Reproduce

  1. Log in to application.
  2. Allow the session to passivate.
  3. Re-log in to the application.


Root Cause



A defect or configuration issue in the operating environment.

The passivated Requestors and corresponding pages were not cleaned. There were entries in both the tables which dated back to January. The large backlog resulted in a Delete from the pr_page_store, to timeout. Hence, some of the pages were deleted. However, the corresponding requestors from pr_sys_context were still in the table.



Resolution



Perform the following local-change:
  1. Truncate the below tables to cleanup the backlog of the expired passivated requestors.

    - pr_page_store
    - pr_sys_context table

     
  2. Ensure that the ClusterAndDBCleaner agent is running on one node and the tables are cleaned regularly.

Published December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us