Support Article
Bulk upload operator failing for SFA product
SA-20116
Summary
The bulk upload feature of the Pega Sales Force Automation (SFA) framework does not work properly. Eventually it shows an error when selecting "Territory".
Error Messages
Errors:
• SFAOperator:** .crmOperatorAccess: ** ** No records were found for the lookup with keys : {pyRuleSet=PegaCRM-SFA; pyPassCurrentParamPageForRespDT=; pyClassName=PegaCRM-Data-SFA-OperatorAccess; pyLookupClassName=PegaCRM-Data-SFA-OperatorAccess; pyDefinitionKey=RULE-DECLARE-PAGES D_OPERATORACCESS #20150120T121220.415 GMT; pyPageStructure=page; pyUserIdentifier=rthomas012; pyResDataTransform=}
Steps to Reproduce
Login to the System as SFASysAdmin then launch the "SFA for Sales Ops" portal.
- Select tools on the left navigation.
- Click on Bulk Upload.
- Select Operators from dropdown 1 and CSV from drop down 2 and give a csv file containing the Operators List and Click Create button.
- Click on Submit button. The operators are uploaded Successfully.
- Open an operator using the Operator navigation tool bar on the left.
- Double Click on the operator to edit the operator.
- Click on the Actions Menu on the right and Select Update Access and Permissions.
- Observe that the screen does not render properly after clicking Update Access and Permission.
- Click the check box “Use Default OperatorAccess?”
- Select a Territory (create one) and click on any part of the screen.
- Observe the error.
Root Cause
After upload the operator from the bulk load, updating the operator access, generates an exception because it couldn't load the operator access. With the exception, the user is unable to update it and save.
Resolution
Apply HFix-26047
Published February 26, 2016 - Updated December 2, 2021
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