Support Article
Cannot connect to PDC
SA-83051
Summary
Unable to connect the system to the Pega Predictive Diagnostic Cloud (PDC).
Error Messages
com.pega.pegarules.pub.services.ResourceUnavailableException: SOAP service failed
sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
Steps to Reproduce
- Provide a link to PDC in the monitored system.
- Connect to PDC
Root Cause
The issue occurred due to the lack of certificate chain in the Java trustStore.
Resolution
Perform the following local-change:
Ensure that the correct trustStore is in use. If -Djavax.net.ssl.trustStore is configured, it overrides the location of the default trustStore.
Upgrade Java to the most current version supported by the Pega if the trustStore is out of date.
As a local-change, import the PDC Public Certificate to the trustStore.
Tags:
Published August 19, 2019 - Updated December 2, 2021
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