Support Article
Cannot open the System Queue Management in SMA
SA-23158
Summary
Unable to browse the System Queue Management page in SMA due to an exception.
Error Messages
Exception during engine invocation: com.pega.pegarules.management.internal.SystemQueueManagementAPI.SystemQueueSummary
com.pega.pegarules.pub.context.PRQueueException: System Queue class System-Queue- maps to non-existent table 'PEGADATA.pr_sys_queues_bix'
at com.pega.pegarules.session.internal.async.agent.QueueManagerImpl.getTablesForDescendents(QueueManagerImpl.java:1521)
at com.pega.pegarules.session.internal.async.agent.QueueManagerImpl.getQueueSummary(QueueManagerImpl.java:1551)
.
.
Steps to Reproduce
1. Open the SMA.
2. Select a node.
3. Expand Agent Management.
4. Select System Queue Management.
Root Cause
The BIX tables were missing from the environment.
Resolution
Perform the following local-change:
1. Designer Studio > Application > Distribution > Import.
2. Select the BIX archive.
3. Choose Enable advance mode, and click Next.
4. In the next screen just select "Automatic: PRPC applies the....." option, and click View or Download SQL DDL.
5. Select the DDL corresponding to the schema details, and use the DDL to create the tables.
Published May 21, 2016 - Updated October 8, 2020
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