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Support Article

Case creation screen not coming properly for remote case-FCM

SA-19694

Summary



2 applications - 1 ABC (non-CS) application and 1 CS (built on Customer Service framework) application are using FCM and have configured FCMR database to view remote cases (ABC cases) from the CS portal. User can open/create cases from the ABC portal, but when we try to open/create cases through CS application - the UI of the cases is broken. We are using IAC gateway with Websphere Application Server. 

Error Messages



There is no error message, case creation harness is coming improperly.


Steps to Reproduce



1. Open Client Service Application portal.
2. Try to create one new case through phone call.
3. Add task - Create New Remote case intent task (FCM).
4. Case creation harness is opening improperly. The UI is completely broken. 


Root Cause

  • This is an upgrade from PRPC 6.3 and CPM 6.3 to PRPC 7.1.8 + CPM 7.1.4
  • There is 1 machine/ 1 node with 2 applications - 1 ABC (non-CS) application and 1 CS (built on Customer Service framework) application
  • Case creation harness is displayed improperly on chrome and mozilla firefox but it is displayed fine for IE8
  • Tried customizing skin but no luck. The default portal of the user who is trying to login remotely was pyCaseManager so no issues with rule resolution. 
  • A reverse proxy was being used with IAC gateway 
  • Specifying the IP Address instead of the host name for both system and gateway urls worked fine
  • The Gateway URL was set to use the full host name "xxx-xx-xx.domain.com" and not the short host name. One must use the same URL, as mentioned in the Gateway URL, to access PRPC to avoid browser same origin policy. 
  • When the cases are opened from CS portal, the static resources are not fetched. Gateway logs with debug level set to FINER had a number of http 400 errors. 
  • noticed from the above gateway snaps that the latest gateway war from 7.1.8 distribution is not being used. The Pega 7 logo is missing. 

Resolution

Same short host name or the full hostname for both gateway and the system url must be used. The configuration should be the same on gateway and remote case configuration. It is required that the URLs presented at runtime and in the browser for the web application page must match the one specified as part of the gateway URL. This includes the protocol, full host name, domain name, and port number. Having different urls results in browser same origin policy issues as also explained in the following PDN article: https://pdn.pega.com/setting-gatewayurl-configuration-parameter

Use the corresponding gateway war that is shipped along with the PRPC distribution. After upgrade from 6.x to 7.1.8, we must use the gateway war from 7.1.8 distribution. This should resolve the issue. 

Published February 26, 2016 - Updated December 2, 2021

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