Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Case dependency does not work if the dependent case is reopened

SA-58327

Summary



Case dependency does not work if the dependent case is reopened.


Error Messages



Not Applicable.


Steps to Reproduce

  1. Define two case, Case A and Case B
  2. Configure a Wait shape in Case A in such a way that Case A should wait till Case B is resolved.
  3. Set the 'To be Resolved' option on the Wait shape configuration
  4. Create a case for Case A and Case B each
  5. Process the Case A instance till the Wait shape. The Case A instance waits for the Case B instance
  6. Resolve the Case B instance and check the Case A instance. Case A instance is also resolved
  7. Create another instance for Case A
  8. Reopen the already resolved instance of Case B
  9. Process the newly created Case A. Though case B instance is reopened, the Case A instance is resolved with out waiting for the Case B instance


Root Cause



This issue was determined to be a product enhancement request.


Resolution

An enhancement request, FDBK-26533, has been created for consideration by Pega Product Management.


 

Published July 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us