Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Case is not routed to Default Assignee of Unavailable Operator

SA-49147

Summary



Assignment is not routed to Default Assignee of Unavailable operator (substitute operator).


Error Messages



Not Applicable


Steps to Reproduce

  1. Set Operator A as Unavailable for a specific period.
  2. Set 'Default to assignee' as Operator B.


  3. Open a case from the Manager Operator ID.
  4. Transfer a case to Operator A with the pyTransferAssignment flow action

Note: All the operators belong to the same workgroup.


Root Cause



The pyTransferAssignment flow action does not consider if the operator is available or not. It assigns the case to the operator without checking the availability since Pega supports the availability of the operator functionality for router activities, such as ToWorkList.


Resolution

The pyTransferAssignment flow action has a pyReassignAssignment activity which post processes the flow action.

Since it is an Available rule; perform either of the following local-changes:

  • Customize the pyReassignAssignment activity.
  • Use the ToWorkList router activity to reassign the case.

Published May 23, 2018 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us