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Support Article

Cases get stuck in work basket after moving to broken queque

SA-89199

Summary

Cases move to a broken queue and get stuck in the work basket. Error occurs in the broken queue. However, the user is unable to identify which entry causes the error.


Error Messages


ORA-00001: unique constraint (ABC_DATA.PC_HISTORY_WORK_PK) violated 


Steps to Reproduce


 

Service Level Agreement (SLA) rule is configured with the activity running, upon reaching the dead line. The deadline is set to three minutes.


Root Cause



The issue is caused in multinode environments due to getCurrentTimeStampUnique.

Resolution


 

The issue is fixed in 7.4.1 with Rule Utility Function (RUF) getCurrentTimeStampThreadUnique. 


 

Published October 8, 2020

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