Support Article
Character 'e' getting appended in error message
SA-25757
Summary
When there are multiple messages on a single field, character 'e' gets appended at the end of every message.
Error Messages
Not Applicable.
Steps to Reproduce
1. Create a boolean property.
2. Create an activity with two property-set-messages on the boolean property.
3. Embed the boolean property in a section as a checkbox.
4. Configure the checkbox to run the activity on click event.
Root Cause
In the RUF pzAddMessages the '\n' is being replaced as (unicode for linefeed) but since this is not being terminated with a semicolon,the character 1 of the next message is being treated as a part of this. So e becomes the character 'e' and gets appended in the message.
Resolution
Apply HFix-28527 to resolve the issue.
Published August 3, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.