Support Article
Chat client on mobile browser disconnects
SA-54110
Summary
The below issues occur after establishing a chat connection with a CSR:
- The chat interaction disconnects on switching to other applications or on locking the screen
- The client is not notified when the chat ends. However, the CSR receives the below message:
The chat has ended. Customer has disconnected.
The issues occur on iOS and Android mobile platforms, while using Chrome and Safari browsers.
Error Messages
Not Applicable
Steps to Reproduce
Case 1
- Open the chat URL
- Establish a chat connection with a CSR
- Lock the phone or switch to other applications
Case 2
- Open the chat URL
- Establish a chat connection with a CSR
- Do not lock the phone or switch to other applications
Root Cause
A defect in Pegasystems’ code or rules.
Resolution
Apply HFix-42518.
Published August 19, 2019 - Updated December 2, 2021
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