Support Article
Chatbot script cannot initiate chat request to agent
SA-97942
Summary
On integrating the Pega Chatbot and Mashup script to the same website, the Chatbot script cannot initiate the chat request to the agent. However, the Mashup code loads correctly.
Error Messages
Not Applicable
Steps to Reproduce
- Include Create New Work Mashup code in to the webpage.
- Download the web Chatbot files from the Self Service portal and include in the same webpage.
- Load the webpage.
- Complete the Create New Work functionality.
- Initiate a chat request.
Root Cause
This behavior is as per Pega product design.
The Mashup code and the Chatbot script cannot be integrated in to the same webpage.
Resolution
Here’s the explanation for the reported behavior:
The limitation with Pega or Mashup until Platform Pega 8.2 is that only one session is established 'per domain'. .
Perform the following local-change (outside of the Pega application):
At the Infra level, use a different virtual domain with a 'Reverse proxy' server which points to the same Pega application. The Create New Work Mashup and Chatbot Mashup must point to different domains which internally direct the request to the same Pega application.
However, from Pega Platform 8.3, with the new URL Semantics support which the engine provides, multiple Mashups can run on the same domain with different Operator contexts.
Published July 15, 2020 - Updated December 2, 2021
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