Support Article
Check out failed
SA-23183
Summary
When a rule is privately checked out and a ruleset version is open, the user can check-in the rule. The application will ask the user to enter a comment, and the rule will be saved into the open ruleset with an updated timestamp. However, if the user instead clicks Save-As button, the privately checked out rule will be saved in the new ruleset version without requesting comments, nor updating the time stamp. A check-out error message appears, but the save completes. Save-As should not be available to ensure the user correctly checks in the updated rule with valid comments and timestamp.
Error Messages
Check out failed. A checked out version with the same keys already exists. Please check-in that record first.
Steps to Reproduce
- Privately check out a rule from a locked ruelset version.
- Make some modifications.
- Use the Save-As button to save it to an open ruleset version.
Root Cause
This issue was determined to be a product enhancement request.
Resolution
An enhancement request, FDBK-15316, has been created for consideration by Pega Product Management.
Published May 16, 2016 - Updated October 8, 2020
Have a question? Get answers now.
Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.