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Support Article

Claim Payment export shows Claim Unit records not Payments made

SA-32413

Summary



After performing Make Payment, if you click View History and export data to Excel, the data is exported for a Claim
Unit (for example, Collision Insured Vehicle) instead of for the particular payment made.


Error Messages



Not Applicable


Steps to Reproduce

  1. Log in with <user_name>_SysAdmin@<domain_name>.com in Pega Claims for Insurance (PCI Framework Application)
  2. Open the Case Manager portal.
  3. Create a case named Notice of Loss – Personal Auto.
  4. Enter a Date and select a Country, and then click Next.
  5. For Role of Loss, select Insured and enter <first_name> and <last_name> in the First and Last Name fields, respectively. Then click Next.
  6. Select a policy and click Next.
  7. Select any Cause of Loss and enter 1 as the value for the field "How many vehicles were involved?"
  8. Enter address details in Loss Location Details and click Next.
  9. Click Next in the section Emergency Service Details.
  10. Select a vehicle in the field "Which vehicle was involved?" and select Yes for "Was this vehicle damaged?" field. Then click Next.
  11. Click Next in the Vehicle Damage Details screen.
  12. Click Next in the Enter Driver Info screen.
  13. Click Next in the Enter Passenger Info screen.
  14. Select No for the field "Was there any property damage?" and click Next.
  15. Select No for the field "Were there any witnesses?" and click Next.
  16. Click Submit in the Accept Loss Information screen.
  17. Open the Claim File created.
  18. Open a Claim Unit, for example, Comprehensive Insured Vehicle.
  19. For Action, click Make Payment, select Single as the payment mode, and enter any pertinent information in the mandatory fields of the form.
  20. Click Make Payment.
  21. Click Manage Payments.
  22. Click Actions > View History on any row. Five (5) items are displayed for the selected payment record.
  23. Click Export to Excel and then open the exported file.
    In the exported file, more than 10 records are displayed.
    The records displayed are the audit trail of the claim unit instead of the five (5) records of the particular payment.
    The five (5) records of the payment made in Step 19 and viewed in the History (Step 22) should be displayed.


Root Cause



On click of View History, the grid is in the context of Manage Payments; therefore, it loads the history details properly.
But on click of the Excel button, it is trying to get the context of claim unit instead of the local action, Manage Payments. Therefore, the system shows the history details of the claim unit instead of the payments made.

Resolution



Apply HFix-31305.

 

Published January 26, 2017 - Updated December 2, 2021

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