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Support Article

Client jar not found in database error from DMa

SA-2574

Summary



User is getting an error while downloading the client jar file from Deployment Manager(DMA) after Real Time Project (RTP) deployment is successful.

Failed to download client jar: Client jar not found in data base.

Failed to download client jar: Exception creating client jar files - Service unregistered java.lang.NullPointerException

<Oct 16, 2014 5:04:55 PM MDT> <Warning> <EJB> <BEA-010065> <MessageDrivenBean threw an Exception in onMessage(). The exception was:
java.lang.reflect.InvocationTargetException.
java.lang.reflect.InvocationTargetException
at weblogic.ejb.container.internal.EJBRuntimeUtils.throwInternalException(EJBRuntimeUtils.java:181)
at weblogic.ejb.container.manager.MessageDrivenManager.createBean(MessageDrivenManager.java:321)
at weblogic.ejb.container.pool.MessageDrivenPool.createBean(MessageDrivenPool.java:174)
at weblogic.ejb.container.pool.MessageDrivenPool.getBean(MessageDrivenPool.java:99)
at weblogic.ejb.container.internal.MDListener.execute(MDListener.java:542)

Error Messages



Failed to download client jar: Client jar not found in data base.


Steps to Reproduce



Login to deployment manager (DMa) then edit RTP and click on download wsdl or client jar


Root Cause



Visual Business Director (VBD) module enabled and not created required JMS, JDBC and workManager resources in the application server.


Resolution



The “cdm.enable.vbd.publishing” flag/parameter set to false in the RTDS_CONFIG_PARAMETERS table under Real Time Decisioning Service (RTDS) schema to disable VBD

Published January 31, 2016 - Updated October 8, 2020

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