Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Collaborated email does not embed Pega URL correctly



When sending a request through collaborate invite, the Pega URL is missing prweb.

For example, http://your_URL:your_port/PRServlet

Error Messages

Not Applicable

Steps to Reproduce

Click invite for collaborated mail request and the request is sent to the intended recipient through mail with a Pega URL. This URL is missing the "prweb" part.

Root Cause

The Public Link URL was configured without prweb. Pega_procom_pegaprocomutilities.getPublicLinkURL()  fetches the Public Link URL value from Data Admin System Setting (DASS) cache (Public Link URL can be updated from the Pega > System > Settings > URL. It will be stored in DASS Pega-ProCom.PublicLinkURL). If the DASS value is empty, it constructs the Public URL as pxRequestor.pxReqContextURI/pxRequestor.pxReqServletName


Update the Public Link URL through Pega > System > Settings > URL. Include the "prweb" part as in the following:


Published January 31, 2016 - Updated October 8, 2020

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us