Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Column Populator Utility for LINK_ATTACHMENT is taking 43 hours

SA-12001

Summary



Column Populator Utility for LINK_ATTACHMENT is taking 43 hours in Pega 7. There are close to 2.4 million records in our environment. This application is upgraded from Pega 6.2 sp2 to Pega 7.1.7.

Error Messages



Not applicable

Steps to Reproduce

  1. run the column populator utility against large number of work objects.

Root Cause



The root cause of this problem is defect/misconfiguration in the operating environment. column utility was executed in single threaded and executed from desktop.

Resolution



The explanation for this behavior is as follows, which reduced the total time significantly.
  1. Execute column utility in parallel with data or pzinskey range. (refer https://pdn.pega.com/pegarules-database/how-to-use-the-column-populator-utility)
  2. Execute column utility in database or in application server where Pega application is deployed.
Suggest Edit

Published July 9, 2015 - Updated October 8, 2020

Did you find this content helpful? Yes No

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us