Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

Connect-SOAP rule throws RemoteApplicationException

SA-20364

Summary



When you invoke a Connect-SOAP rule, it fails with the below error.

Error Messages



Error in JSP execution
com.pega.pegarules.pub.services.RemoteApplicationException: SOAP service failed


Steps to Reproduce



1) Invoke a Connect-SOAP rule

Root Cause



The out of the box Soap connect activity in PRPC throuws RemoteApplicationException when the response from the SOAP service provider is not null and not a Java IO exception. The behavior is as per design of the activity invokeAxis2 and not a bug. To prevent the RemoteApplicationException we need to update the invokeAxis2 step 15 to Handel the customer specific error response   

Resolution



Perform the following local-change: 

Modify invokeAxis2 step # 15 code and replace

throw new RemoteApplicationException("SOAP service failed", e);
with
oLog.error("SOAP service failed", e);


Related PDN link https://pdn.pega.com/support-articles/error-level-logging-soap-failure-responses

​This will print the stack trace in the log file but the activity execution will continue. One can write customized log messages as well along with the fault messages received from the service provider. 

Published March 16, 2016 - Updated October 8, 2020

Was this useful?

100% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us