Support Article
Connection to SMA failed with SOAP error
SA-36374
Summary
Connection to System Management Application (SMA) fails with SOAP error with stack trace below:
Error Messages
com.pega.jmx.ui.util.JMXClientException: Exception getting MBean Server connection. Fail to instantiate WASJMXConnector
Failed to get mbean server connection
SMA ERROR: Failed to create admin client
ADMC0016E: The system cannot create a SOAP connector to connect to host XXX.XXX.XXX at port 20115.
Steps to Reproduce
1. Login to Designer Studio as [email protected].
2. Open System >Operations-SMA.
3. Configure SMA properties.
4. Connect to SMA. Fails with SOAP connection error.
Root Cause
This is an environment issue.
Resolution
User has defined two custom properties in websphere as below.
https.proxyHost=XXX.XXX.XXX
https.proxyPort=XXXX
Issue is resolved after removing the above properties.
Published April 27, 2017 - Updated October 8, 2020
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