Support Article
CPMSearchResultsKC – Declare_AgentStatus does not exist
SA-3173
Summary
Running a Service Intent in CPM the error appears in the log below error.
111.222.333.44|127.0.0.1 OperatorName - The access group in Declare_AgentStatus Page does not contain Pega-SearchEngine Ruleset
java.lang.NullPointerException
at com.pegarules.generated.activity.ra_action_cpmsearchresultskc_9a95fdc2925014b850a22355a75932d7.step22_circum0
(ra_action_cpmsearchresultskc_9a95fdc2925014b850a22355a75932d7.java:2033)
Steps to Reproduce
Running a Service Intent in CPM the error appears in the log.
Root Cause
The root cause of this problem is a defect in Pegasystems’ code/rules RULE-OBJ-ACTIVITY EMBED- CPMSEARCHRESULTSKC
Resolution
HFix-10249 : CPMSearchResultsKC – Declare_AgentStatus does not exist
To fix this issue we commented out line 22 where the exception for search is no longer needed in Pega 7.
Tags:
Published January 31, 2016 - Updated December 2, 2021
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