Skip to main content

This content has been archived and is no longer being updated. Links may not function; however, this content may be relevant to outdated versions of the product.

Support Article

CSV output not generated for BIX extract



CSV output file is not generated for Business Intelligence Exchange (BIX) Extract. However, when using XML instead, the CSV output file is generated.

Error Messages

[PegaRULES-Batch-36] [ ] [your_app:01.01.01] (internal.access.ExtractImpl) ERROR  your_user - Unable to process Failed to download data: code: 0 SQLState: 22P02 Message: ERROR: invalid input syntax for type numeric: "" 
  Position: 192 
DatabaseException caused by prior exception: org.postgresql.util.PSQLException: ERROR: invalid input syntax for type numeric: "" 
  Position: 192 
 | SQL Code: 0 | SQL State: 22P02

Steps to Reproduce


Root Cause

High-throughput mode is used by default in certain circumstances.
In this case, however, the requirements were not met.

For more information, refer to:


  1. Create the following Dynamic System Setting (DSS) to disable the high-throughput mode.

    Ruleset: Pega-Engine
    Purpose: prconfig/bix/useHighThroughputDownloadForCSV/default
    Value: False

  2. Restart the application.

Published March 1, 2019 - Updated December 2, 2021

Was this useful?

0% found this useful

Have a question? Get answers now.

Visit the Collaboration Center to ask questions, engage in discussions, share ideas, and help others.

Did you find this content helpful?

Want to help us improve this content?

We'd prefer it if you saw us at our best.

Pega Community has detected you are using a browser which may prevent you from experiencing the site as intended. To improve your experience, please update your browser.

Close Deprecation Notice
Contact us