Support Article
CTI auto register extension not working
SA-41518
Summary
CTI auto register extension is not working in latest PegaCall 7.1.3 ML4.
Users are using data transform pySample of class ChannelServices-Embed-CTI-Credentials to populate .pyExtension from Operator rule form and making .pyAutoLogin as True.
The result of the above change is when user logs into Pega portal, they are automatically logged in/gets registered to that particular extension without explicitly clicking on the telephone icon on the portal header and logged in with that particular extension.
Error Messages
Not Applicable
Steps to Reproduce
1. Login to Pega.
2. Initiate a screen pop through CTI system without explicitly logging into the extension by clicking on phone icon.
3. Observe no screen pop happens.
Root Cause
An issue in the custom application code or rules:
User has customized code to achieve the auto login functionality, which was working fine in earlier version of CTI.
Upon debugging, user found that the data pages and the relevant activities were to be updated for these functionality are changed.
Resolution
Perform the following local-change:
Modify the activity DPLoadChannelPreferences by adding a 'Property-Set' step to set the value to 'true' for property '.pyAutoLogin' and update data pages D_CPMUserPrefs_Channels and D_pyMyCTICredentials with other relevant information.
Tags:
Published March 24, 2018 - Updated October 8, 2020
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